re = /^\w+/m
str = 'Tsuru Stork greeting for a long last life. Unisex
Yama Mountain; Restrainer; Unisex
Yuka A bright Star Unisex
Yumi A beautiful archery bow Unisex
Yuna The archer Unisex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end