re = /^testing_v(?P<sm>[0-9\.]+([\-][0-9]+)?)?(\_[0-9A-Za-z-]+)?$/m
str = 'testing_v14.8.1-12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end