// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^testing_v(?P<sm>[0-9\.]+([\-][0-9]+)?)?(\_[0-9A-Za-z-]+)?$").unwrap();
let string = "testing_v14.8.1-12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}