import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x-i) # FREE-SPACE MODE, case-sensitive\n\n"
+ "(?(DEFINE)\n"
+ " (?<ws>[\\r\\n\\t\\x20]*)\n"
+ " (?<str>\"(?:\\\\[rntbf\\\\\\/] | [[:xdigit:]]{4} | [^\\\\\"[:cntrl:]])*\")\n"
+ " (?<bool>true|false)\n"
+ " (?<nil>nil)\n"
+ " (?<num>-?\\d+(?:\\.\\d+)?)\n"
+ " (?<elem>(?:(?&str)|(?&bool)|(?&nil)|(?&num))(?&ws))\n"
+ " (?<comma>,(?&ws))\n"
+ ")\n\n"
+ "# JSON Array\n"
+ "\\[ (?&ws)\n"
+ "(?:\n"
+ " (?:\n"
+ " (?&elem) | (?R)(?&ws)\n"
+ " )\n"
+ " (?(?=(?&comma)(?:(?&elem)|[\\[\\{]))(?&comma))\n"
+ ")*\n"
+ "\\]\n\n"
+ "| # Or\n\n"
+ "# JSON Object\n"
+ "\\{ (?&ws)\n"
+ "(?:\n"
+ " (?&str) (?&ws) \n"
+ " : (?&ws)\n"
+ " (?:\n"
+ " (?&elem) | (?R)(?&ws)\n"
+ " )\n"
+ " (?(?=(?&comma)[\"\\[\\{])(?&comma))\n"
+ ")*\n\n"
+ "\\}";
final String string = "{\"foo\":\"bar\", \"bools\":true,\n"
+ "\"digits\":42,\n"
+ "\"objects\":{ \"cool\" : \"beans\"},\n"
+ "\"arraystoo\":[ \n\n"
+ "{\"thisworks\":\"yep\"},\n"
+ " {\"thisworkstoo\":\"uh, huh!!\"}\n"
+ "]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}