use strict;
my $str = '{"foo":"bar", "bools":true,
"digits":42,
"objects":{ "cool" : "beans"},
"arraystoo":[
{"thisworks":"yep"},
{"thisworkstoo":"uh, huh!!"}
]
}';
my $regex = qr/(?x-i) # FREE-SPACE MODE, case-sensitive
(?(DEFINE)
(?<ws>[\r\n\t\x20]*)
(?<str>"(?:\\[rntbf\\\/] | [[:xdigit:]]{4} | [^\\"[:cntrl:]])*")
(?<bool>true|false)
(?<nil>nil)
(?<num>-?\d+(?:\.\d+)?)
(?<elem>(?:(?&str)|(?&bool)|(?&nil)|(?&num))(?&ws))
(?<comma>,(?&ws))
)
# JSON Array
\[ (?&ws)
(?:
(?:
(?&elem) | (?R)(?&ws)
)
(?(?=(?&comma)(?:(?&elem)|[\[\{]))(?&comma))
)*
\]
| # Or
# JSON Object
\{ (?&ws)
(?:
(?&str) (?&ws)
: (?&ws)
(?:
(?&elem) | (?R)(?&ws)
)
(?(?=(?&comma)["\[\{])(?&comma))
)*
\}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}