import re
regex = re.compile((r"(?x-i) # FREE-SPACE MODE, case-sensitive\n\n"
r"(?(DEFINE)\n"
r" (?<ws>[\r\n\t\x20]*)\n"
r" (?<str>\"(?:\\[rntbf\\\/] | [[:xdigit:]]{4} | [^\\\"[:cntrl:]])*\")\n"
r" (?<bool>true|false)\n"
r" (?<nil>nil)\n"
r" (?<num>-?\d+(?:\.\d+)?)\n"
r" (?<elem>(?:(?&str)|(?&bool)|(?&nil)|(?&num))(?&ws))\n"
r" (?<comma>,(?&ws))\n"
r")\n\n"
r"# JSON Array\n"
r"\[ (?&ws)\n"
r"(?:\n"
r" (?:\n"
r" (?&elem) | (?R)(?&ws)\n"
r" )\n"
r" (?(?=(?&comma)(?:(?&elem)|[\[\{]))(?&comma))\n"
r")*\n"
r"\]\n\n"
r"| # Or\n\n"
r"# JSON Object\n"
r"\{ (?&ws)\n"
r"(?:\n"
r" (?&str) (?&ws) \n"
r" : (?&ws)\n"
r" (?:\n"
r" (?&elem) | (?R)(?&ws)\n"
r" )\n"
r" (?(?=(?&comma)[\"\[\{])(?&comma))\n"
r")*\n\n"
r"\}"), flags=re.MULTILINE)
test_str = ("{\"foo\":\"bar\", \"bools\":true,\n"
"\"digits\":42,\n"
"\"objects\":{ \"cool\" : \"beans\"},\n"
"\"arraystoo\":[ \n\n"
"{\"thisworks\":\"yep\"},\n"
" {\"thisworkstoo\":\"uh, huh!!\"}\n"
"]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")