# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/(?:web.archive.org\/web\/\d*(?:|if_)|archive.*\/.*\/)\/((?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n?]+)).*$"
test_str = ("https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html\n"
"https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php\n"
"https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324\n"
"https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug\n"
"https://archive.ph/2021.07.09-181138/https://www.dominio.net/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.