// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/(?:web.archive.org\/web\/\d*(?:|if_)|archive.*\/.*\/)\/((?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n?]+)).*$").unwrap();
let string = "https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
https://archive.ph/2021.07.09-181138/https://www.dominio.net/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}