using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name"":[\'""]([^\'""]+)[\'""].+category"":[\'""]([^\'""]+)[\'""].+price"":[\'""]([^\'""]+)[\'""].+link"":[\'""]([^\'""]+)[\'""].+foto"":[\'""]([^\'""]+)[\'""]";
string input = @"id"":""1223834"",
""name"":""LG OLED55BX3LB"",
""brand"": ""LG"",
""category"":""Telewizory"",
""category-url"":""telewizory-led-lcd-plazmowe"",
""root-category"":""TV, Audio"",
""price"":""5799.00"",
""link"":""/telewizory-led-lcd-plazmowe/lg-oled55bx-tv-oled-uhd-4k-lg.bhtml"",
""foto"":""/foto/4/71327190465/ea08610ee555fb998e75984be75ec019/lg-oled55bx-tv-oled-uhd-4k-lg,71327190465_2.jpg""";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}