package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Usi)name":[\'"]([^\'"]+)[\'"].+category":[\'"]([^\'"]+)[\'"].+price":[\'"]([^\'"]+)[\'"].+link":[\'"]([^\'"]+)[\'"].+foto":[\'"]([^\'"]+)[\'"]`)
var str = `id":"1223834",
"name":"LG OLED55BX3LB",
"brand": "LG",
"category":"Telewizory",
"category-url":"telewizory-led-lcd-plazmowe",
"root-category":"TV, Audio",
"price":"5799.00",
"link":"/telewizory-led-lcd-plazmowe/lg-oled55bx-tv-oled-uhd-4k-lg.bhtml",
"foto":"/foto/4/71327190465/ea08610ee555fb998e75984be75ec019/lg-oled55bx-tv-oled-uhd-4k-lg,71327190465_2.jpg"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}