import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"name":[\'"]([^\'"]+)[\'"].+category":[\'"]([^\'"]+)[\'"].+price":[\'"]([^\'"]+)[\'"].+link":[\'"]([^\'"]+)[\'"].+foto":[\'"]([^\'"]+)[\'"]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
id":"1223834",
"name":"LG OLED55BX3LB",
"brand": "LG",
"category":"Telewizory",
"category-url":"telewizory-led-lcd-plazmowe",
"root-category":"TV, Audio",
"price":"5799.00",
"link":"/telewizory-led-lcd-plazmowe/lg-oled55bx-tv-oled-uhd-4k-lg.bhtml",
"foto":"/foto/4/71327190465/ea08610ee555fb998e75984be75ec019/lg-oled55bx-tv-oled-uhd-4k-lg,71327190465_2.jpg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}