re = /\bFC\b(?:(?!\bFC\b).)*?1/m
str = ': FC Relacionado con Paciente FC Protocolo1 FC Comunicacion entre Profesionales1 FC Disponibilidad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end