package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*$`)
var str = `This is a sample sentence.
Let's se how it
matches these lines.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}