$re = '/^\s*$/m';
$str = 'This is a sample sentence.
Let\'s se how it
matches these lines.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);