re = /^\s*$/m
str = 'This is a sample sentence.
Let\'s se how it
matches these lines.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end