# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(?: DE: (.*))(?: ID: (.*)){0,1}(?: MOTIF: (.*))(?: REF: (.*)){0,1}/Tiers:\t$1 \rid:\t$2 \rmotif:\t$3\r\r/mg;t' <<< "PRELEVEMENT EUROPEEN 2001427553 DE: MUTUELLE DE L'INDUSTRIE DU PETROLE ID: FR69MIP108863 MOTIF: Prelevement 42CXK 024 de MIP du 01/
VIR RECU 0485970259S DE: CPAM VAR MOTIF: 180930001235180930001235 REF: 18093000123"