re = /.*(?: DE: (.*))(?: ID: (.*)){0,1}(?: MOTIF: (.*))(?: REF: (.*)){0,1}/m
str = 'PRELEVEMENT EUROPEEN 2001427553 DE: MUTUELLE DE L\'INDUSTRIE DU PETROLE ID: FR69MIP108863 MOTIF: Prelevement 42CXK 024 de MIP du 01/
VIR RECU 0485970259S DE: CPAM VAR MOTIF: 180930001235180930001235 REF: 18093000123'
subst = 'Tiers:\\t$1 \\rid:\\t$2 \\rmotif:\\t$3\\r\\r'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result