import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(?:trade|www)\\.kucoin\\.com\\/(?:trade\\/)?([A-Z]{3,5})-USDT";
final String string = "https://www.kucoin.com/trade/GGG-USDT\n"
+ "https://trade.kucoin.com/GEEQ-USDT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}