import re
regex = re.compile(r"https:\/\/(?:trade|www)\.kucoin\.com\/(?:trade\/)?([A-Z]{3,5})-USDT", flags=re.MULTILINE)
test_str = ("https://www.kucoin.com/trade/GGG-USDT\n"
"https://trade.kucoin.com/GEEQ-USDT")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")