re = /https:\/\/(?:trade|www)\.kucoin\.com\/(?:trade\/)?([A-Z]{3,5})-USDT/m
str = 'https://www.kucoin.com/trade/GGG-USDT
https://trade.kucoin.com/GEEQ-USDT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end