const regex = new RegExp('Rule\\((?P<flow_number>[^,]+),\\s(?P<protocol>[^,]+),\\s(?P<from_ip>\\[[^\\]]+\\]),\\s(?P<to_ip>\\[[^\\]]+\\]),\\s(?P<port>[^,)]+)\\)', 'gm')
const str = `Rule(F1, HTTPS TCP, ['ip', 'ip'], ['www.google.ca', '8.8.8.8'], 443)
Rule(F2, HTTPS TCP, ['ip', 'ip'], ['ip'], 443)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}