$re = '/Rule\((?P<flow_number>[^,]+),\s(?P<protocol>[^,]+),\s(?P<from_ip>\[[^\]]+\]),\s(?P<to_ip>\[[^\]]+\]),\s(?P<port>[^,)]+)\)/m';
$str = 'Rule(F1, HTTPS TCP, [\'ip\', \'ip\'], [\'www.google.ca\', \'8.8.8.8\'], 443)
Rule(F2, HTTPS TCP, [\'ip\', \'ip\'], [\'ip\'], 443)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);