$re = '/:[a-zA-Z0-9_]*/';
$str = 'SELECT cID, cTIME, cDATA FROM tMyTable WHERE cTIME = \'0000-00-00 00:00:00\' and cID > :param1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);