re = /:[a-zA-Z0-9_]*/
str = 'SELECT cID, cTIME, cDATA FROM tMyTable WHERE cTIME = \'0000-00-00 00:00:00\' and cID > :param1;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end