package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s*key1\s+(?'key1'.+))?(?:\s*key2\s+(?'key2'.+))?`)
var str = ` key1 p1, p2 ,p3 key2 p4,p5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}