re = /(?:\s*key1\s+(?'key1'.+))?(?:\s*key2\s+(?'key2'.+))?/m
str = ' key1 p1, p2 ,p3 key2 p4,p5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end