$re = '/(?:\s*key1\s+(?\'key1\'.+))?(?:\s*key2\s+(?\'key2\'.+))?/m';
$str = ' key1 p1, p2 ,p3 key2 p4,p5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);