package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^a-zA-Z0-9!$%&*:;#~@])`)
var str = `afdskljfalsfhaljsf jdsalfhajslfjdsf haskjlfjdskfa sdfl;dasj fas kjdfs2345tg!@*%(&)&^%$@#@!!$%^&%($%$##@$@>?"{P}P@#!é45049sgfg~~~\`\`\`j;fad;fadsfafds
{":
fd
:"L'KM"JNH¨MJ'KJ¨HN'GFDMG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}