re = /([^a-zA-Z0-9!$%&*:;#~@])/
str = 'afdskljfalsfhaljsf jdsalfhajslfjdsf haskjlfjdskfa sdfl;dasj fas kjdfs2345tg!@*%(&)&^%$@#@!!$%^&%($%$##@$@>?"{P}P@#!é45049sgfg~~~```j;fad;fadsfafds
{":
fd
:"L\'KM"JNH¨MJ\'KJ¨HN\'GFDMG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end