$re = '/([^a-zA-Z0-9!$%&*:;#~@])/';
$str = 'afdskljfalsfhaljsf jdsalfhajslfjdsf haskjlfjdskfa sdfl;dasj fas kjdfs2345tg!@*%(&)&^%$@#@!!$%^&%($%$##@$@>?"{P}P@#!é45049sgfg~~~```j;fad;fadsfafds
{":
fd
:"L\'KM"JNH¨MJ\'KJ¨HN\'GFDMG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);