using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:sun|mon|tues|wednes|thurs|fri|satur)day\/\K[^?]+(?=\?weatherType)";
string input = @"https://www.google.com/today/SUNDAY/abcde2.hopeho.3345GETD?weatherType=RAOM&...
https://www.google.com/today/Monday/jbkwe3.ho4eho.8495GETD?weatherType=WHTDSG&...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}