$re = '/(?i)(?:sun|mon|tues|wednes|thurs|fri|satur)day\/\K[^?]+(?=\?weatherType)/m';
$str = 'https://www.google.com/today/SUNDAY/abcde2.hopeho.3345GETD?weatherType=RAOM&...
https://www.google.com/today/Monday/jbkwe3.ho4eho.8495GETD?weatherType=WHTDSG&...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);