#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9])|(29)(Feb|FEB)([02468][048]|[13579][26]))$"
Local $sString = "1Jan18 abcd" & @CRLF & _
"1Jan18" & @CRLF & _
"01Jan18" & @CRLF & _
"31Jan18" & @CRLF & _
"31jan18" & @CRLF & _
"31jAN18" & @CRLF & _
"31JAn18" & @CRLF & _
"31JaN18" & @CRLF & _
"31JAN18" & @CRLF & _
"28Feb18" & @CRLF & _
"29Feb18" & @CRLF & _
"29Feb20" & @CRLF & _
"31Mar18" & @CRLF & _
"30Apr18" & @CRLF & _
"31Apr18" & @CRLF & _
"31May18" & @CRLF & _
"30Jun18" & @CRLF & _
"31Jun18" & @CRLF & _
"31Jul18" & @CRLF & _
"31Aug18" & @CRLF & _
"30Sep18" & @CRLF & _
"31Sep18" & @CRLF & _
"31Oct18" & @CRLF & _
"30Nov18" & @CRLF & _
"31Nov18" & @CRLF & _
"31Dec18"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")