import re
regex = re.compile(r"^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9])|(29)(Feb|FEB)([02468][048]|[13579][26]))$", flags=re.MULTILINE)
test_str = ("1Jan18 abcd\n"
"1Jan18\n"
"01Jan18\n"
"31Jan18\n"
"31jan18\n"
"31jAN18\n"
"31JAn18\n"
"31JaN18\n"
"31JAN18\n"
"28Feb18\n"
"29Feb18\n"
"29Feb20\n"
"31Mar18\n"
"30Apr18\n"
"31Apr18\n"
"31May18\n"
"30Jun18\n"
"31Jun18\n"
"31Jul18\n"
"31Aug18\n"
"30Sep18\n"
"31Sep18\n"
"31Oct18\n"
"30Nov18\n"
"31Nov18\n"
"31Dec18")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")