import Foundation
let pattern = #"^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9])|(29)(Feb|FEB)([02468][048]|[13579][26]))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1Jan18 abcd
1Jan18
01Jan18
31Jan18
31jan18
31jAN18
31JAn18
31JaN18
31JAN18
28Feb18
29Feb18
29Feb20
31Mar18
30Apr18
31Apr18
31May18
30Jun18
31Jun18
31Jul18
31Aug18
30Sep18
31Sep18
31Oct18
30Nov18
31Nov18
31Dec18
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)