$re = '/_{3}(?=.*[a-zA-Z_])(.*[a-zA-Z_])_{3}/m';
$str = '___string_string___
___test___
__something__
___sda1231___
______';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);