re = /_{3}(?=.*[a-zA-Z_])(.*[a-zA-Z_])_{3}/m
str = '___string_string___
___test___
__something__
___sda1231___
______'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end