using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\sid=\""landingImage\""\s[^""]*\""{"(http.:.*?)&";
string input = @" id=""landingImage"" data-a-dynamic-image=""{"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UX675_.jpg":";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}