$re = '/\sid=\"landingImage\"\s[^"]*\"{"(http.:.*?)&/m';
$str = ' id="landingImage" data-a-dynamic-image="{"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UX675_.jpg":';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);