re = /\sid=\"landingImage\"\s[^"]*\"{"(http.:.*?)&/m
str = ' id="landingImage" data-a-dynamic-image="{"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UX675_.jpg":'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end