package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/api\/customer\/\d+`)
var str = `/api
/api/customer/10
/api/customer/1
/api/customer10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}