re = /\/api\/customer\/\d+/m
str = '/api
/api/customer/10
/api/customer/1
/api/customer10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end