$re = '/\/api\/customer\/\d+/m';
$str = '/api
/api/customer/10
/api/customer/1
/api/customer10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);