#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[([^]]*)\]"
Local $sString = "AAAAAA 00 [00] AAAAAA [00]"
Local $sSubst = "($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)