package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^]]*)\]`)
var str = `AAAAAA 00 [00] AAAAAA [00]`
var substitution = "($1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}