$re = '/\[([^]]*)\]/m';
$str = 'AAAAAA 00 [00] AAAAAA [00]';
$subst = "($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;