package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)&extension=([^\s&]*)`)
var str = `https://example.com/?gclid=something&extension=me-trying-stuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}