$re = '/&extension=([^\s&]*)/m';
$str = 'https://example.com/?gclid=something&extension=me-trying-stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);