re = /&extension=([^\s&]*)/m
str = 'https://example.com/?gclid=something&extension=me-trying-stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end