import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>";
final String string = "</style></head><body dir=\"ltr\" style=\"max-width:21cm;margin-top:1cm; margin-bottom:1cm; margin-left:1cm; margin-right:1cm; \">\n"
+ " <p class=\"P11\">PRE-REGISTRATION</p>\n"
+ " <p class=\"P11\">FIL_RI_CHOP</p>\n"
+ " <p class=\"P1\"><span class=\"T3\">We confirm the completion of the pre-registration CRF for the patient <span class=\"T1\">1</span> enrolled in the study <span class=\"T1\">FIL_RI_CHOP</span>.</span><a id=\"_GoBack\"/><span class=\"T1\"></span></p>\n"
+ " \n"
+ " <p class=\"P1\">\n"
+ " <span class=\"T3\">Date: </span><span class=\"T1\">2018-08-03<br/></span>\n"
+ " <span class=\"T3\">Patient's Code: </span><span class=\"T1\">1<br/></span>\n"
+ " <span class=\"T3\">Center: </span><span class=\"T1\">17_Terni_S.Maria<br/></span>\n"
+ " <span class=\"T3\">User: </span><span class=\"T1\">site_admin<br/></span></p><p class=\"P1\">\n"
+ " \n"
+ " <span class=\"T3\">Uffici Studi FIL</span></p><p class=\"P1\">\n"
+ " <span class=\"T3\">Fondazione Italiana Linfomi ONLUS</span></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}